Input drivers

  • How do I configure input for X?
    Look at the how to configure input documentation.

  • Why can’t I kill X through Ctrl+Alt+Backspace?
    That’s explained in the above-mentioned documentation.

Video drivers

All drivers

  • What’s wrong with the DPI setting?
    By the default, the X server uses 96 DPI, as seen on upstream bug #23705 (in particular Keith’s comment). A particular DPI setting can be set through desktop environment’s preferences, through the -dpi X server command line option (see Xserver’s manual page), or through xrandr’s --dpi option.

  • How do I get some info about 3D support?
    Look at the instructions to build mesa, there are a few commands to learn about 3D support, the current driver, etc.

Ati driver

  • Why is it I’m getting low performances, or even crashes?
    Make sure you have installed the firmware-linux package. The driver might still be working without the firmware, but using code paths which aren’t supported as well as the “normal” ones.

Intel driver

  • Why isn’t it working?
    KMS is mandatory, as documented in its README.Debian (view it online: You probably disabled KMS or didn’t include it in your kernel configuration if you’re using a custom kernel.

  • X is crashing all the time with my “old” Intel card. What can I do?
    Unfortunately, old cards are not very well supported, and you can’t do much more than switching to a generic driver, like fbdev or vesa, as documented in README.Debian (view it online: Please note that you need to disable KMS if you want to use the vesa driver. A minimal xorg.conf would look like:

Section "Device"
    Identifier "MyBuggyCard"
    Driver     "fbdev"

Nouveau driver

  • Why isn’t it working?
    Since it’s still considered experimental by its authors, the interfaces aren’t stable yet, so the driver has particular dependencies on the kernel, which are documented in README.Debian (view it online: for squeeze, for sid).


Session management

  • How to start a bare X session (without Gnome, KDE, etc.)?
    Assuming there’s no X running on the :1 display, run this from a VT:

startx /usr/bin/xterm -- :1